Uudised

Kontrolli ID-kaardi tarkvara versiooni Mac OS X 10.4 ja 10.5 arvutites

03.05.2013

Tuvastatud on viga Ideelabori poolt loodud ID-kaardi tarkvaras Mac OSX 10.4 ja 10.5 operatsioonisüsteemile. 

Vigane komponent sisaldus paigalduspakkides idCardLight-OSX10.x, mida levitati enne 2010. aasta oktoobrit ka installer.id.ee lehel. 

Antud tarkvara kasutades on teatud e-teenustes (panga maksed, DigiDoc Portaal jms) ID-kaardiga allkirjastamisel tekkinud kehtetu allkirjaga digiallkirjastatud failid. Kui on endiselt arvuteid, kus kasutatakse vigast tarkvara siis tuleks see koheselt eemaldada, et vältida kehtetute failide tekkimist. Vaata lisainfot.

Probleemse tarkvara olemasolu arvutis saab tuvastada ja eemaldada järgmiselt. Mõlemad veebilehitsejad kasutavad sama komponenti ning piisab kui tehakse läbi üks neist. 

Safari veebilehitsejas

1. Ava Safari veebilehitseja. Liigu Help menüüsse ning ava seal valik Installed Plug-ins.

2. Kui leiad avanevast nimekirjast npidcard.plugin, siis on sinu arvutis vigane tarkvara.

3. Eemaldamiseks mine kataloogi /Library/Internet Plug-Ins leia sealt fail nimega npidcard.plugin ja kustuta see. Kustuta seejärel fail ka prügikastist (Trash). 

4. Kui nüüd uuesti minna Help menüüsse ning avada seal valik Installed Plug-ins ei ole avanevas nimekirjas enam viidet npidcard.plugin.

Firefox veebilehitsejas

1. Ava Firefox veebilehitseja. Liigu Tools menüüsse ja ava seal valik Add-ons

2. Avaneb Add-ons Manager. Liigu valikule Plugins ja kui leiad sealt ID-card signing plugin siis on sinu arvutis vigane tarkvara. 

3. Vajutades Disable nuppu on võimalik vigane plugin deaktiveerida. 

  

4. Täielikuks eemaldamiseks mine kataloogi /Library/Internet Plug-Ins leia sealt fail nimega npidcard.plugin ja kustuta see. Kustuta seejärel fail ka prügikastist (Trash). 

5. Taaskäivita Firefox. Kui nüüd uuesti minna Tools menüüsse ning avada seal valik Add-ons ei ole enam nimekirjas ID-card signing plugin. Kui Firefoxile taaskäivitust ei tehtud võib avaneda ka järgmine pilt. Vajuta Remove nuppu ja soovitavalt taaskäivita Firefox.

 

Mac OSX 10.4 versioonile ei ole olemas riiklikul tellimusel loodud ID-tarkvara. Mac OSX 10.5 ei ole enam täna riikliku ID-tarkvara poolt toetatud operatsioonisüsteem.  Mõlemal juhul on ID-kaardi kasutamiseks vajalik operatsioonisüsteemi uuendus. Alternatiivina on võimalik kasutusele võtta Mobiil-ID.

Lisainfot saab abi at id dot ee  


KÜSI ABI

Kui sa ei leidnud oma küsimusele vastust, kirjuta meie meeskonnale.



  • Vaata juhendit
  • Hinda oma arvutikasutusoskust, et saaksime anda paremaid juhiseid

         

  • Vigane kontrollsõna


    Loo uus kontrollsõna
    CAPTCHA Image

Kuidas saame artiklit parandada, et sellest rohkem abi oleks?
Saada Sulge